Chapter 15 Using Software Sequencers

The VS-1680 can be used to create complete recordings, including tracking, editing, mixing, and
even CD production. Synchronizing the VS-1680 with a MIDI sequencer allows you to add MIDI
instruments without actually recording them to tracks on the VS-1680. This can reserve the VS-1680
tracks for recording vocals, guitar, etc. Because the VS-1680 includes a 26-channel digital mixer,
you can mix and process up to 10 inputs from a MIDI-based sequencing system with the tracks in the
VS-1680.

This chapter will explain how to synchronize the VS-1680 with many of the currently available

software sequencing programs. For the purposes of this chapter, it is assumed that you have a good
working knowledge of the VS-1680 as well as general computer operations.

l. Common Terms

A. MIDI Clock

Used for synchronizing two or more MIDI devices. MIDI Clock (sometimes called MIDI Beat Clock)
sends timing information based on beats-per-minute (e.g. 120bpm). MIDI Clock is available on almost
all sequencers and drum machines and is usually used in conjunction with Song Position Pointer (see
below).

B. MIDI Time Code (MTC)

Another method of synchronizing two or more MIDI devices. Unlike MIDI Clock, MTC uses time-based
information (Hours, Minutes, Seconds, Frames) to synchronize devices and does not reference a
specific tempo or time signature. Because MTC uses a more complicated signal, it is not
implemented on some devices. When available, MTC is usually more desirable for synchronizing
audio recorders and tape decks. MTC is sometimes used in conjunction with MIDI Machine Control
(see below).

C. MIDI Machine Control (MMC)

Transport and locate commands (PLAY, STOP, RECORD, etc.) that are transmitted through MIDI.
MMC is used to control a device (e.g. the VS-1680) remotely. Another protocol (usually MTC) is used
to provide the sync signal.

D. Song Position Pointer (SPP)
This message allows you to locate to any point within a song (e.g., Bar 33, beat 4). SPP is normally
used with MIDI Clock. It does not work with MTC.

E. Synchronization

When using a sequencer or a drum machine with the VS-1680, it is often desirable for the two
devices to start and stop at the same time. This is referred to as synchronization. Typically, you
have a "Master" device and a "Slave" device. When the master device is started, the slave device
will start at the same time. MIDI devices primarily use two methods for synchronization: MIDI Clock
(often used with Song Position Pointer) or MIDI Time Code (sometimes used with MIDI Machine
Control).

F. Tracks

Tracks on the VS-1680 are similar to tracks on a sequencer. Just as you can record an instrument
(or multiple instruments) on a track of the VS-1680, you can record MIDI information on a sequencer
track.

G. MIDI Interface
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A MIDI Interface is used to connect MIDI devices to your computer. There are various types of MIDI
interfaces available to choose from. The setup procedure for your MIDI interface will vary depending
on the type of interface and computer you are using. On the Macintosh, MIDI interfaces are usually
connected to the printer, modem, or USB port(s). The interface is then controlled by either the
sequencing software itself or by one of three programs: Apple MIDI Manager, OMS (Opcode), or
FreeMIDI (Mark of the Unicorn). On Windows based computers, MIDI interfaces are usually
connected to the serial port, parallel port, USB port, or directly to a sound card. Each interface will
likely have its own software drivers that must be installed and configured for the interface to operate
correctly.

MIDI Interface Troubleshooting Tips:

If you are having trouble getting your MIDI interface to work properly, there are a number of common
troubleshooting techniques you can use to determine where the problem lies. On the Macintosh,
most setup problems are the result of conflicting extensions in your system folder. Try disabling any
extensions that are not absolutely necessary for the program to run and restart your computer. On
Windows based computers, most setup problems are the result of conflicting IRQ and/or Port Address
settings. Make sure that each of the devices connected to your computer is set to its own IRQ and
Port Address and that the corresponding software driver(s) reflects those settings. Defective or
incorrectly connected MIDI cables are another common problem encountered when configuring a
MIDI sequencing setup.

1. Cakewalk Pro Audio

Cakewalk Pro Audio is available for IBM compatible computers. Version 8.0 was used for this
explanation.

A. Cakewalk as Master Device

There are two methods for synchronizing the VS-1680 with Cakewalk: Using MTC/MMC with Cakewalk
as the master, or using MIDI Clock with the VS-1680 as the master. Using the first method, the Play,
Stop, etc. buttons in Cakewalk will control the VS-1680.

1. Connections
1. Connect the MIDI OUT port of your MIDI interface to the MIDI IN port of the
VS-1680.
2. Connect the MIDI OUT port of the VS-1680 to the MIDI IN port of your MIDI
interface.
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2. Cakewalk Settings

1. Click on "Project Options..." in the Tools menu.

2. Click on the "Clock" tab.

3. Click on "SMPTE/MTC" under Source.

4. Click on "30 Frame Non-Drop" under SMPTE/MTC Format.

5. Click on the "MIDI Out" tab.

6. Click on "Transmit MMC" under MIDI Machine Control.

7. Use your mouse to select "17" under Timecode Master’s Unit ID.

8. Click on "OK”".

3. VS-1680 Settings

1. Hold [SHIFT] and press [EXT SYNC].

2. Move the cursor to Sync Source and use the TIME / VALUE dial to select
"INT".

3. Move the cursor to Sync Gen and use the TIME / VALUE dial to select
"MTC".

4. Move the cursor to Sync MTC Type and use the TIME / VALUE dial to select
"30".

5. Press [F6(Exit)], then press [F4(MIDI)].

6. Move the cursor to Device ID and use the TIME / VALUE dial to select "17".

7. Move the cursor to MIDI Thru and use the TIME / VALUE dial to select "Out".

8. Move the cursor to SyseEx Rx and use the TIME / VALUE dial to select "On".

9. Move the cursor to MMC and use the TIME / VALUE dial to select "Slave".

10. Press [PLAY(DISPLAY)] to return to the Playlist display.

Click on the play icon in Cakewalk. The VS-1680 should begin playback in sync with Cakewalk. If
not, check the MIDI connections and driver settings in your computer.
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B. VS-1680 as Master Device
The second method for synchronizing the VS-1680 with Cakewalk uses MIDI Clock messages. Using
this method the VS-1680 will control the playback of Cakewalk.

1. Connections
1. Connect the MIDI OUT port of the VS-1680 to the MIDI IN port of your MIDI
interface.
2. Cakewalk Settings
1. Click on "Project Options..”. in the Tools menu.
2. Click on the "CLOCK" tab.
3. Click on "MIDI Sync" under Source.
4, Click on "OK".
3. VS-1680 Settings
1. Hold [SHIFT] and press [EXT SYNC].
2 Move the cursor to Sync Source and use the TIME / VALUE dial to select
"INT".
3. Move the cursor to Sync Gen and use the TIME / VALUE dial to select
"MIDIclk".
4, Press [F6(EXxit)], then press [F4(MIDI)].
5. Move the cursor to MIDI Thru and use the TIME / VALUE dial to select "Out".
6. Press [PLAY(DISPLAY)] to return to the Playlist display.

Click on the play icon in Cakewalk and "Waiting for MIDI Sync" will be displayed. Press [PLAY] on
the VS-1680 and Cakewalk will begin playback in sync with the VS-1680.

l[1l.  Cubase VST

Cubase VST is available for Mac or IBM compatible computers. Version 4.0 on a Macintosh was
used for this explanation.

A. Cubase as Master Device
There are various methods that can be used to synchronize Cubase with the VS-1680. This example
will use MTC with Cubase controlling the playback of the VS-1680.

1. Connections

1. Connect the MIDI OUT port of your MIDI interface to the MIDI IN port of the VS-
1680.
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2. Cubase Settings
1. Click on "Synchronization" in the Options menu.
2. Click on the pop-up menu by MIDI Timecode and click on the Interface that is
connected to the VS-1680.
3. Click on the pop-up menu by Frame Rate, and click on "30FPS”. Click on
"OK".
3. VS-1680 Settings
1. Hold [SHIFT] and press [EXT SYNC].
2. Move the cursor to Sync Source and use the TIME / VALUE dial to select
"EXT".
3. Move the cursor to Sync MTC Type and use the TIME / VALUE dial to select
"30".
4. Press [F6(Exit)], then press [F4(MIDI)].
5. Move the cursor to Device ID and use the TIME / VALUE dial to select "17”.
6. Move the cursor to MIDI Thru and use the TIME / VALUE dial to select "Out”.
7. Press [PLAY(DISPLAY)] to return to the Playlist display.

Press [PLAY] on the VS-1680 (it will start flashing). Start playback in Cubase, the VS-1680 should
start playing in sync with Cubase. If not, check your MIDI connections and driver settings in your

computer.

B. VS-1680 as Master Device
The next example also uses MTC, with the VS-1680 controlling the playback of Cubase.

1. Connections
1. Connect the MIDI OUT port of the VS-1680 to the MIDI IN port of your MIDI
interface.
2. Cubase Settings
1. Click on "Synchronization" in the Options menu.

2.

3.
4,
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Click on the pop-up menu by From Input and click on the interface that is
connected to the VS-1680.

Click on the pop-up menu by SMPTE Sync and click on "MTC".

Click on the pop-up menu by Frame Rate and click on "30FPS”.
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5. Click on "OK," then click on the SYNC box in the Transport control bar so that

it darkens.
3. VS-1680 Settings

1. Hold [SHIFT] and press [EXT SYNC].

2. Move the cursor to Sync Source and use the TIME / VALUE dial to select
"INT".

3. Move the cursor to Sync Gen. and use the TIME / VALUE dial to select
"MTC".

4, Move the cursor to Sync MTC Type and use the TIME / VALUE dial to select
"30".

5. Press [F6(Exit)], then press [F4(MIDI)].

6. Move the cursor to MIDI Thru and use the TIME / VALUE dial to select "Out”.

7. Press [PLAY(DISPLAY)] to return to the Playlist display.

Press [PLAY] on the VS-1680 and Cubase should start playback in sync with the VS-1680. If it does

not, check your MIDI connections and the driver settings in your computer.

V. Loqic Audio

Logic Audio is available for Mac or IBM compatible computers. Version 3.5 for Macintosh was used

for this explanation.

A. Logic as Master Device

There are several methods that can be used to synchronize Logic with the VS-1680. This example

uses MTC and MMC, with Logic controlling the playback of the VS-1680.

1. Connections

1. Connect the MIDI OUT port of your MIDI interface to the MIDI IN port of the VS-

1680.
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2. Logic Settings

1. Click on "Open Arrange" in the Windows menu.

2. Click on "MIDI Options" in the Options sub menu.

3. Click on "Transmit MTC (MIDI Time Code)" so it has an "X" in its box.

4, Click on "MIDI Machine Control (MMC)" so there is not an "X" in its box.

5. Click on "OK".

6. Click on "Synchronization" in the Options menu.

7. Click on "General" and click on "Intern" from the Sync Mode pop-up menu.

8. Click on "30" in the Frame Rate (fps) pop-up menu, click on the 30 button.
Click on OK.

3. VS-1680 Settings

1. Hold [SHIFT] and press [EXT SYNC].

2. Move the cursor to Sync Source and use the TIME / VALUE dial to select
"EXT".

3. Move the cursor to Sync MTC Type and use the TIME / VALUE dial to select
"30".

4, Press [PLAY(DISPLAY)] to return to the Playlist display.

Press [PLAY] on the VS-1680 and it will start to blink. Now you can click on PLAY in Logic and the
VS-1680 will begin playing back as well.

B. VS-1680 as Master
The next example uses MTC, with the VS-1680 controlling the playback of Logic.

1. Connections
1. Connect the MIDI OUT port of the VS-1680 to the MIDI IN port of your MIDI
interface.
2. Logic Settings
1. Click on "Open Arrange" in the Windows menu.
2. Click on "MIDI Options" in the Options sub menu.
3. Click on "Auto Sync In" so it has an "X: in its box.
4, Click on "OK".
3. VS-1680 Settings
1. Hold [SHIFT] and press [EXT SYNC].
2. Move the cursor to Sync Source and use the TIME / VALUE dial to select
"INT".

Move the cursor to Sync Gen and use the TIME / VALUE dial to select "MTC".
Press [F6(EXxit)], then press [F4(MIDI)].

Move the cursor to MIDI Thru and use the TIME / VALUE dial to select "Out”.
Press [PLAY(DISPLAY)] to return to the Playlist display.

S

Press [PLAY] on the VS-1680 and Logic will play in sync with the VS-1680. Logic will automatically
recognize the frame rate that the VS-1680 is using. If it is different than the frame rate set in Logic, a
pop-up window will appear allowing you to adjust Logic’s frame rate accordingly.

V. Diqital Performer

Digital Performer is available for Macintosh computers. Version 2.41 was used for this explanation.
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A. FreeMIDI

FreeMIDI is a software program used by Performer to coordinate the various devices in your MIDI
studio. When connecting a VS-1680 to Performer, the first thing you need to do is create a VS-1680
device in your FreeMIDI setup. You should only

have to do this once.
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FreeMIDI Configuration

1. From Performer, click on "Edit FreeMIDI Configuration” in the Basics Menu.

2. Click on "Create Device" from the Configuration menu. The FreeMIDI Device Specification
window will appear.

3. Click on "Roland" in the Manufacturer pop-up menu and click on "Other" in the Model pop-up
menu.

4, Click in the Name box and type "VS-1680".

5. Click in the Device ID box and select "17”.

6. Click on "Receives MTC", “Transmits MTC," and "MIDI Machine" under the Properties menu

7. Click on "Icons..”. and select an icon for the VS-1680. Click on "OK".

8. Click and drag from the MIDI IN and OUT on the VS-1680 icon to the MIDI IN and OUT on
the MIDI Interface icon. You should now see them connected on the screen.

9. Click on "Return" in the MIDI menu to return to Performer.

B. Performer as Master Device

There are several methods that can be used to synchronize Performer with the VS-1680. This
example uses MTC and MMC, with Performer controlling playback on the VS-1680.

1. Connections
1. Connect the MIDI OUT port of your MIDI interface to the MIDI IN port of the
VS-1680.
2. Connect the MIDI OUT port of the VS-1680 to the MIDI IN port of your MIDI
interface.
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2. Performer Settings
1. Click on "Receive Sync" in the Basics menu.
2. Click on the MIDI interface port that is connected to the VS-1680 in the Sync
to Port pop-up menu.
Click on "MTC, DTL, or DTLe" under Type of Sync.
Click on "30 fps" under SMPTE Frame Format.
Click on "OK".
Click on "Transmit Sync..”. in the Basics menu.
Click on "None" under Transmit beat clocks via port(s).
Click on "OK".
Click on "Slave to External Sync" in the Basics menu. A check mark will
appear next it.

©oN O ~®

3. VS-1680 Settings

1. Hold [SHIFT] and press [EXT SYNC].

2. Move the cursor to Sync Source and use the TIME / VALUE dial to select
"INT".
Move the cursor to Sync Gen and use the TIME / VALUE dial to select "MTC".
Move the cursor to Sync MTC Type and use the TIME / VALUE dial to select
"30".
Press [F6(EXxit)], then press [F4(MIDI)].
Move the cursor to Device ID and use the TIME / VALUE dial to select "17”.
Move the cursor to MIDI Thru and use the TIME / VALUE dial to select "Out”.
Move the cursor to SysEx.Rx and use the TIME / VALUE dial to select "On”.
Move the cursor to MMC and use the TIME / VALUE dial to select "Slave”.
0. Press [PLAY(DISPLAY)] to return to the Playlist display.

pw

PO ~NOO!

Click on the Play icon in Performer. The VS-1680 should begin playback in sync with Performer. If
not, check your FreeMIDI settings and the MIDI connections to your computer.

C. VS-1680 as Master Device
The next example uses MTC with the VS-1680 controlling the playback of Performer.

1. Connections
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1. Connect the MIDI OUT port of the VS-1680 to the MIDI IN port of your MIDI

interface.
2. Performer Settings
1. Click on "Receive Sync..”. in the Basics menu.
2. Click on "MTC, DTL, or DTLe" under Type of Sync.
3. Click on "30 fps" under SMPTE Frame Format.
4, Click on "OK".
5. Click on "Slave to External Sync" in the Basics menu so that there is a check
mark next to it.
3. VS-1680 Settings
1. Hold [SHIFT] and press [EXT SYNC].
2. Move the cursor to Sync Source and use the TIME / VALUE dial to select
"INT".
3. Move the cursor to Sync Gen. and use the TIME / VALUE dial to select
"MTC".
4, Move the cursor to Sync MTC Type and use the TIME / VALUE dial to select
"30".
5. Press [F6(Exit)], then press [F4(MIDI)].
6. Move the cursor to MIDI Thru and use the TIME / VALUE dial to select "Out”.
7. Press [PLAY(DISPLAY)] to return to the Playlist display.

Click on the play icon in Performer (it will start flashing). Press [PLAY] on the VS-1680 and Performer
should begin playback in sync with the VS-1680. If not, check your FreeMIDI settings and the MIDI
connections to your computer.

VI. Vision DSP

Vision is available for Macintosh and IBM compatible computers. Version 4.1 on a Macintosh was
used for this explanation.

A. Open MIDI System

OMS is a software program used by Vision to coordinate the various devices in your MIDI studio.
When using a VS-1680 with Vision, the first thing you need to do is create a VS-1680 device in your
OMS setup. You should only have to do this once.
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OMS Configuration

Click on "OMS Studio Setup..”. in the Setups menu in Vision.

Click on "New Device" in the Studio menu.

Click on "Roland" in the pop up menu next to Manuf.

Click on "Other" in the pop-up menu next to Model.

Click in the Name box and type "VS-1680".

Click in the is controller and is multitimbral boxes so that a checkmark appears.

Click in the Receive Channels boxes for all 16 MIDI channels so that a checkmark appears.

Click in the Receives and Sends boxes for MTC and MMC, and click in the Sends box for

MIDI Beat Clock so that a checkmark appears.

9. Click on "Device ID" and select "16".

10. Click "OK".

11. Click on the VS-1680 icon in the open window. Click on "Device Icon" in the Studio menu and
choose the desired icon for the VS-1680.

12. Click on "Save," followed by "Quit" in the File menu.
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B. Vision as Master Device
There are several methods that can be used to synchronize Vision with the VS-1680. This example
uses MTC and MMC with Vision controlling playback in the VS-1680.

1. Connections
1. Connect the MIDI OUT port of your MIDI interface to the MIDI IN port of the
VS-1680.
2. Connect the MIDI OUT port of the VS-1680 to the MIDI IN port of your MIDI
interface.
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2. Vision Settings
1. Click on "Sync Options..”. in the Options menu.
2. Click on "MIDI Time Code" in the pop-up menu next to Receive Sync.
3. Click on "30 fps, non drop" in the pop-up menu next to SMPTE Format.
4, Click on OK.
3. VS-1680 Settings
1. Hold [SHIFT] and press [EXT SYNC].
2 Move the cursor to Sync Source and use the TIME / VALUE dial to select
"INT".
3. Move the cursor to Sync Gen and use the TIME / VALUE dial to select "MTC".
4, Move the cursor to Sync MTC Type and use the TIME / VALUE dial to select
"30".
5. Press [F6(EXxit)], then press [F4(MIDI)].
6. Move the cursor to Device ID and use the TIME / VALUE dial to select "17”.
7. Move the cursor to MIDI Thru and use the TIME / VALUE dial to select "Out”.
8. Move the cursor to SysEx Rx and use the TIME / VALUE dial to select "On”.
9. Move the cursor to MMC and use the TIME / VALUE dial to select "Slave”.
10. Press [PLAY(DISPLAY)] to return to the Playlist display.

Click on the play icon in Vision. The VS-1680 should begin playback in sync with Vision. If not, check
the MIDI connections and OMS settings in your computer.

C. VS-1680 as Master Device
The next example uses MTC, with the VS-1680 controlling the playback of Vision.

1. Connections
1. Connect the MIDI OUT port of the VS-1680 to the MIDI IN port of your MIDI
interface.
2. Vision Settings
1. Click on "Sync Options..”. in the Options menu.
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2. Click on "MIDI Time Code" in the pop-up menu next to Receive Sync.

3. Click on "30 fps, non drop" in the pop-up menu next to SMPTE Format.

4, Click on "Remote Start," so it is checked.

5. Click on "OK".

3. VS-1680 Settings

1. Hold [SHIFT] and press [EXT SYNC].

2. Move the cursor to Sync Source and use the TIME / VALUE dial to select
"INT".

3. Move the cursor to Sync Gen and use the TIME / VALUE dial to select "MTC".

4, Move the cursor to Sync MTC Type and use the TIME / VALUE dial to select
"30".

5. Press [F6(Exit)], then press [F4(MIDI)].

6. Move the cursor to Device ID and use the TIME / VALUE dial to select "17”.

7. Move the cursor to MIDI Thru and use the TIME / VALUE dial to select "Out.

8. Press [PLAY(DISPLAY)] to return to the Playlist display.

Click on the play icon in Vision, it will start to flash. Press [PLAY] on the VS-1680 and Vision should
start playback in sync with the VS-1680. If not, check the MIDI connections and OMS settings in

your computer.
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